Migrating to libgda-4, some APIs changes